Difference between revisions of "How to Prevent Plugins from Affecting your WordPress Website"


(new article)
 
 
Line 28: Line 28:
  
 
When possible, select a paid theme over a free theme. Free themes may become abandoned by their developers leaving them incompatible with the latest version of WordPress, or the latest version of your plugins. If you cannot install a paid theme at this time, try choosing a free theme that offers a paid version as these are more likely to be maintained.
 
When possible, select a paid theme over a free theme. Free themes may become abandoned by their developers leaving them incompatible with the latest version of WordPress, or the latest version of your plugins. If you cannot install a paid theme at this time, try choosing a free theme that offers a paid version as these are more likely to be maintained.
 +
 +
[[Category:WordPress]]

Latest revision as of 15:30, 22 April 2022

With thousands of plugins available for use, while many can be useful, there are also many plugins that can hinder the performance or security of your website. Plugins can cause conflicts with your current WordPress version, theme, or pre-existing plugins or code on your website. In this article, we will be discussing methods to prevent plugins from affecting your website in the first place. Carefully selecting your plugins may save you time and prevent any issues from occurring.

How Plugins Could Potentially Affect your WordPress Website

  1. The plugin uses too many resources – Some plugins can use up all of your resources, which can degrade your website’s performance.
  2. The plugin is not safe – Some malicious plugins exist which can compromise the security of your website. Even plugins that are not intended to be malicious could become susceptible to vulnerabilities.
  3. Your plugin is not compatible with your WordPress theme – Some plugins and themes can conflict with each other. It is important you select reputable plugins and themes that are compatible with each other so errors do not occur.
  4. Your plugin update is not compatible with your website – While it is extremely important to keep both your WordPress version and plugins up to date to avoid security issues, please keep in mind that plugin updates can potentially clash with your current website.

How to Prevent Plugins from Affecting your WordPress Website

Choose Plugins Carefully

We recommend carefully selecting well-established, popular plugins that cover all of the functionality you are looking for. Not only is quality important, but it is also equally important to consider your quantity of plugins. Having too many plugins, especially ones you may no longer need, can clutter your plugin list and cause confusion when troubleshooting your WordPress website.

Before installing any plugin, it is a safe practice to research the plugin first. We recommend checking if the plugin is reputable among other WordPress users. You can explore reviews from other WordPress customers on the official WordPress plugin page https://en-ca.wordpress.org/plugins/. Plugins that are well established will likely have many positive reviews. Plugins that are often rated low, or have little to no reviews may come with more risk of causing potential issues on your website. Please see our article on Discouraged WordPress Plugins for a list of plugins that may negatively affect the performance of your website.


Check your Website After Updates

Plugin updates, while extremely important to maintain the security of your website, can sometimes cause conflicts with existing code on your website, your theme, or other plugins. If an error happens on your website, the first step in troubleshooting is to identify the problem. Instead of updating all plugins at once, update each plugin individually and assess your website afterward. If there are any unexpected changes to your website, the updated plugin is likely the culprit. Monitor your website for PHP errors, loss of functionality, or changes in appearance after each plugin update. If all plugins were updated at once, this could cause a time-consuming process to determine which update affected your website.


Choose your Themes Carefully

Poorly made, unpopular themes can conflict with plugins installed on your website. Themes can become incompatible with your plugins or website which is why they are equally as important to consider when managing your WordPress website. If you are using a page builder plugin, make sure your theme is compatible. For example, a popular site builder plugin, Elementor, is recommended to be used with Elementor-approved themes only. Using a theme that is not compatible with your page builder may cause conflicts.

When possible, select a paid theme over a free theme. Free themes may become abandoned by their developers leaving them incompatible with the latest version of WordPress, or the latest version of your plugins. If you cannot install a paid theme at this time, try choosing a free theme that offers a paid version as these are more likely to be maintained.